B. Upgrade Imaging & Media | Gwulo: Old Hong Kong
Pre-order the new Gwulo book today to get 
special pricefree shippingsigned copies, and a free sample
Details and how to order

B. Upgrade Imaging & Media

Notes from the 'Gwulo in 2016' post:

Upgrade imaging. The software we use to handle images is due for an upgrade, and so is the zooming viewer we use to display them.

Scald:

  1. Set up test server [COMPLETE]
  2. Upgrade to the latest version [COMPLETE]
  3. Show the author who created this atom [COMPLETE]
  4. Link embedded Flickr images back to their page on Gwulo [COMPLETE]
  5. Link Flickr image pages on Gwulo back to their page on Flickr [COMPLETE]
  6. Look into "Flickr problems" - http://gwulo.com/node/32305
  7. Look into "Cannot insert image when using iPad" - http://gwulo.com/comment/36005#comment-36005
  8. Enable caching (how to invalidate a single atom in cache when updated?) [POSTPONED]
  9. Show some progress indicator when searching [FIX #10 MEANS THIS IS NOT NEEDED]
  10. Speed up searching [COMPLETE]
  11. Set gallery, etc., for multi-image uploads [COMPLETE]
  12. Prevent multiple copies of new tags from being created with multi-image uploads
  13. Add support for Youtube videos
  14. Add support for PDF files

Zoomify:

  1. Thomas notes that the image at http://gwulo.com/atom/22520 shows an error message: "Image tile count does not match value in image XML. If the count is invalid display problems can result." See if the viewer upgrade solves this - if not then investigate the problem. (Note that clicking the image will make the error message disappear.) [COMPLETE]
  2. Allow zoom on non-tiled images
  3. Stop generating tiles for mid-sized images
  4. Allow recording zoom and pan in the url.
  5. Allow search-engines to see non-zoomify copy of photo. [IN PROGRESS - Google spider can 'see' zoomify image on page. Will they show in search results?]
Forum: 

I've made that change, and at the same time added "Submitted by" under each image so we can see who created an image page.

eg here's a photo I uploaded to the site: http://gwulo.com/atom/23420

If you look under the photo you will now see "Submitted by David".

But if you look at one I created from Flickr, http://gwulo.com/atom/19207, the text below the photo reads "Submitted by David. View the original image on Flickr." You can click the word Flickr to visit its page on the Flickr website.

Looks to be working ok but please let me know if you experience any problems related to this.

Regards, David

This helps make pages a bit faster to load, but otherwise you shouldn't see any changes. If you do, please let me know!

Regards, David

Nope, several people have reported missing images, which were caused by the caching. I've disabled it again.

(Caching doesn't know about the Zoomify viewer we use. It doesn't load the viewer, so no image is displayed.)

I've just upgraded the Scald software that handles images here on Gwulo. So if you notice anything strange when uploading images, inserting them into text, or viewing them, please let me know.

The search bar on the right used to have an insert tab/feature for each photo. I have got around it by clicking the photo twice to insert.

I saw something similar happen just after the upgrade, but it is working ok for me now.

Please could you let me know what you are using (device / operating system / browser, eg PC / Win 7 / Chrome) when you insert the image?

You've found one workaround is to double-click the image, and another is to drag the image and drop it on the text where you want it to appear, But I'd like to get the insert link working again.

For any other readers who can help, we're talking about the blue "insert" link shown below. Please could you let me know if you see the link, and also let me know the device / operating system / browser you used to test.

Regards, David

photo-list.jpg
photo-list.jpg, by Admin

When using I. E.and Firefox, the insert link appears but not for Chrome.

Unfortunately I can't reproduce the problem here in Chrome on my PC. I guess that an old version of some file is in Chrome's cache, and is causing the problem.

If you're comfortable clearing "Cached images and files" from Chrome's cache, I'll be interested to see if that solves the problem.

But if you're not sure how to do that, or you're ok with the workaround, you can just leave it as it is. I expect it will fix itself sometime in the next few weeks as the cache updates.

When you edit a page, you don't have to wait as long to see the side-bar for inserting images. If you're using that side-bar, searching or viewing later pages of results is also faster.

Thomas noted that the image at http://gwulo.com/atom/22520 showed an error message: "Image tile count does not match value in image XML. If the count is invalid display problems can result." 

I've worked out a fix for the problem, and I've updated all the images I could see were affected by it. But if you still see the error message on any pages, please leave a comment below to let me know.

A little time-saver if you're uploading several photos at one time: you now have the option to choose the gallery once, and all photos will default to that gallery. An improvement over the old method where you had to set the gallery on every photo.

As usual, let me know if you spot any problems.